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Introduction to ArcGIS 10.2 

Overview 
Making maps in ArcMap is very easy: Browse geospatial data in ArcMap and choose an appropriate 

presentation. The table below outlines the steps that this workshop will guide you through. 

 

No. Steps 
Sections 
to check 

Difficulties 

1 Load Geospatial Data into ArcMap 1.1 Data formats and folder connection 

2 
Identify the features and attributes to 
present 

1.2  
Layer order, feature selection, and 
(briefly) frequent-used projections 

3 Define how to show the data 2.2 
Transparency (raster and vector), data 
classification, and layer file 

4 Add maps components 2.3 Geospatial data references 

5 Export maps 2.4 Resolution and file formats 
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1. Browse Geospatial Data 

1.1. Load data 

To launch ArcMap, click: Start -> All Programs -> ArcGIS -> ArcMap 10. By default, a start-up splash 

window will appear once ArcMap has loaded (Figure 1).  

Click OK to proceed. You can ignore all other options. They are redundant. 

 

Figure 1. The start-up splash window of ArcMap 

There are two ways to add data: Click the Add Data  button (Figure 2), which opens a window 

similar to Figure 1. 

 

 
Figure 2. Main Windows with Marks on Add Data and ArcCatalog 

Add Data ArcCatalog 
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Figure 3. The Pop-up Window of "Add Data" 

To browse to the file you want to work with, you can link to the folder containing all these files by 

clicking the Connect to Folder  button shown in Figure 3, then browse to add the folder that 

contains your files and click OK. After that, you can locate the files listed below and add them all at once 

by holding the Ctrl or Shift button while clicking on each selection. Please click the Add button just like 

any other file explorer dialogs in Windows to close the dialog.  

 Public_schools.shp: All public schools in the City of Waterloo 

 waterloo_city.shp: The administrative boundary of the City of Waterloo 

 waterloo_streets.shp: Street network in the City of Waterloo 

When the data is loaded, all files will be listed in the left pane, called the Table of Contents (Figure 4). 

The geographic features (contents) are displayed in the main window, called the Data Frame. The 

toolbars can be found on the periphery of the other two windows.  

 

Connect to 

Folder 
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Frequently-used File Formats in ArcGIS: 
 

 Feature Data: Feature data are usually organized as points, lines, and polygons in vector 
format. 

 
o Shapefile: The most commonly used geospatial data format. Although it appears to 

be one file in ArcMap, a shapefile includes multiple files with the same file name, but 
different extensions. *.shp, *.dbf, and *.shx are necessary components of the shapefile.  
 

o Personal Geodatabase: These files are based on Microsoft Access (*.mdb). From a 
user perspective, the personal geodatabase is essentially a database structure but 
contains geospatial information as well as rows and columns.  
 

o File Geodatabase: A file geodatabase is much like a personal geodatabase except 
that it has more capacity and greater processing capabilities than a personal 
geodatabase. File geodatabases enable users to create datasets, which are like 
subfolders within the geodatabase. These can be used to organize datasets that 
participate in various kinds of spatial networks.  
 

o Further Reading:  
 http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Types_of_g

eodatabases/003n00000007000000/ 
 http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/About_geo

graphic_data_formats/00r90000006r000000/ 
 

 Raster Data: Raster data uses grid to represent a region with values as a “field”. Images 
explicitly have the parameter of resolution. Typical raster data is: 

 
o GeoTIFF: They have the file extension of *.tif. The key difference between normal TIFF 

file and GeoTIFF is that GeoTIFF has projection information. Hence, normal TIFF files 
cannot be correctly added to the desired location. 

o GeoJPEG: Similar to GeoTIFF, but they have *.jpg extension. 
o Usage: Raster data can be air photos, satellite images, elevation data (DEM). But 

raster data tends to be huge and slow to load. 
 

 External Data: ESRI also supports some file formats produced by other vendors due to their 
popularity. Typical ones are: 

 
o AutoCAD: *.dwg files can be added, imported and converted into ArcMap. 
o Google Earth: *.kml files are supported by ArcGIS as well. However, conversion from 

KML into Shapefile is required, which can be done using ArcToolbox or some online 
services. 

o Further Reading: Wikipedia on GIS File Formats 
http://en.wikipedia.org/wiki/GIS_file_formats 

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Types_of_geodatabases/003n00000007000000/
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Types_of_geodatabases/003n00000007000000/
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/About_geographic_data_formats/00r90000006r000000/
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/About_geographic_data_formats/00r90000006r000000/
http://en.wikipedia.org/wiki/GIS_file_formats
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Figure 4. Structure of the Main Window 

 

Table of 
Contents 

Data Frame 
Window 

Toolbars and 
Menus 
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1.2. Add an Esri Basemap 
When users want to overlay a basemap and city boundary (waterloo_city.shp) together to produce a 

map like one you might see on Google Maps, they can add a basemap directly from ArcMap.   

To add a basemap, go to File -> Add data -> Add Basemap Layer (Figure 5) 

 

Figure 5. Adding a basemap from the File menu 

When the Add Basemap dialog box appears, you will see that there are several types to choose from. 

For this tutorial, choose either “Streets” or “Topographic” as your basemap (Figure 6). 

 

Figure 6. Esri Basemaps 

http://maps.google.ca/maps?q=waterloo,+ontario&hl=en&ll=43.48257,-80.533905&spn=0.134519,0.219727&sll=43.470394,-80.538411&sspn=0.016818,0.027466&hnear=Waterloo,+Waterloo+Regional+Municipality,+Ontario&t=m&z=12
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1.3. Browse Geographic Features 
Most of the basic controls for working with data are found in the Tools toolbar (Figure 7). If you cannot 

find this toolbar, please go to Customize -> Toolbars and check the Tools on.   

 

Figure 7. The Tools toolbar with Data Controls 

Most icons are intuitive and self-explained. If you are not sure what function it has, you can hover your 

mouse over that icon. A pop-up text will show and further explanation. In Figure 7, you can see the 

description for the Pan tool when the mouse is hovering over the  icon.   

In addition to the toolbar, some functions on attribute data are put in the pop-up window when you 

right click on one layer (a geospatial data file or a feature class) in the table of contents (Figure 8). When 

you click on “Open Attribute Table”, a table with all information on features will be shown (Figure 9). 
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Figure 8. Pop-up Window with Options on a Layer 

 

Figure 9. Attribute Data Window 

These controls can be classified and summarized into the following table: 

 Geographic Operations Attribute Operations 

Browse 
 

Right-click on the layer (Figure 8 and 9) 

Search/Identify 
  

Select  (Figure 9) 

 

Select by 
Attributes 
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2. Mapping 

2.1. Distinction between Geospatial Data and Map Components 
This section is more concept oriented. To simplify the mapping process, ArcMap offers two ways of 

viewing the map contents: Data View, which focuses on data manipulation and representation; and 

Layout View, which shows you how the map will look on the page, including map elements such as the 

legend, scale bar, north arrow, etc.  

 All data representations should be set in data view. Key operations include the change of layer 

order, symbology customization, layer transparency, labeling, and annotations. Most of data 

representations can be saved in a layer file (*.lyr), because they are more data associated.  

 Layout view shows the virtual map you will get. Layout view works in a What You See Is What 

You Got (WYSIWYG) fashion. The output will be the same as what you see in the layout view, 

where you can add map elements and change the paper and output settings. Map settings will 

be save in an *.mxd file. 

 

Figure 10. Switch between Data View and Layout View 

Switch Menu 

Switch Button 
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2.2. Key Operations of Geospatial Data Representations 
The main operations of changing geospatial data representations are layer order, layer transparency, 

symbology, label, and annotation. Apart from the first one (layer order) and last one (annotations), 

these operations can be found in the pop-up window shown below (Figure 11) byright-clicking the layer 

you want to modify and selecting Properties. The Layer Properties dialog box appears (Figure 12) and 

you can select from the different tabs such as Symbology or Labels as shown below.  

 

Figure 11. Pop-up Window of a Layer's Property 

 

Figure 52. The Property Window 

The following subsections discuss the operations in detail.  

2.2.1. Layer Order and Transparency 

The boundary layer (waterloo_city.shp) can be made to outline the city (i.e. no fill color), which allows us 

to see the underlying basemap. The detailed steps will be introduced after the concept of layer order. 

Layer Order 

ArcMap displays geospatial data according to the order in the table of contents: the bottom layer will be 

drawn on the screen first, the next one up will be drawn on top, and so forth until the uppermost layer. 

Hence, the layer on the top will be drawn last and may cover up other layers. By default, ArcMap orders 

points, lines, polygons, and raster data (images, DEMs, etc) from top to bottom respectively so that 

Properties 

Symbology 

Labels 
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the visibility is maximized. If two layers belong to the same feature class, i.e., point features, the newly 

added one will be on top of the older one. 

When there are multiple raster files, layer visibility and order are important. You can change layer 

visibility by switching the checkboxes to the left of the layer name in the table of contents (Figure 13). 

And the display order can be changed by simply dragging the layer toward or away from the top.   

 

Figure 63. Layer Visibility and Order Control 

Layer Visibility 

When a polygon layer, such as waterloo_city, is added over an image (basemap), the image under the 

polygon is not visible, as in Figure 13. But users often like to only show the polygon’s boundary so that 

the basemap imagery is also visible. In this case, layer transparency and hollow symbology can help.  

To do so, right-click on the polygon layer (waterloo_city) and select Properties (Figure 11). Then under 

the Symbology tab, click on the symbol itself (Figure 14). 

Visibility 
Checkbox 

Drag to change order 

Waterloo City as polygon 
covers the air photo 
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Figure 74. Properties of Symbology 

When the Symbol Selector opens, (Figure 15), you can change the Fill Color to No Color and increase the 

Outline Width from 0.4 to 1.0.  

 

Figure 85. Make Hollow Polygons 

 

 

Layer Transparency: 
An alternative (actually more generic) way of preventing overlaying is to right-click the layer and 
select Properties (Figure 11), then go to the Display tab. You can freely change the transparency 
as the parameter (percentage) of “Transparent” (or “Transparency” for raster layers). 

Symbology Tab 

Click on the Symbol to 
Customize 

Change Fill Color to No Color 

Outline Width 
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2.2.2. Symbology and Label 

Symbology 

Symbology is critical in making maps, which are classified into four categories in ArcMap. Due to its 

complexity, these four categories and their normal usages will be briefly introduced in the note region 

with further reading. We will only focus on symbol customization and classification symbols, which are 

mostly used.  

Please right-click the public_schools layer and select Properties. Then switch to the Symboloy tab and 

click on the Symbol. The Symbol Selector dialog (Figure 16) contains four main parts. In most cases, you 

will simply choose a symbol from the symbol library (other than making hollow polygons mentioned in 

2.2.1.). Depending on the type of feature (point, line, or polygon), the options change accordingly. 

You can type in school and click the search icon (magnifier) to search all symbols related to school 

representations. 

  

Figure 96. Symbology Customization Window with Explanations 

There are cases when you want to differentiate features in a layer based on some attribute. For 

instance, I want to know the type of public school (elementary or secondary), which is the top layer in 

Figure 13. Different types will be symbolized using different colors. To do so, we should right-click on 

the school layer, select Properties, and go to the Symbology tab, which is the same as shown in Figure 

14. But instead of the default Features option, click the Categories option (Figure 17).  

1. Click on the Categories first and make sure the “Unique Value” is chosen; 

2. Draw down the dropbox of Value Field, and select TYPE as the classification attribute; 

3. Click on the Add All Values button to add all distinct values under the TYPE attribute into 

consideration; 

4.  (Optional) Click on the Color Ramp dropbox and select your favourite color schema. 

Professional 
Symbol Library 

Frequently-used Customization 
Options 

Advanced (Full) Options 

Search 
Keywords 
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Figure 107. Classifying Features using Colors 

The result is shown in Figure 18. Please note that you can still customize individual symbol for each 

category (size, shape, etc.) by double-clicking corresponding classes on either the left pane or the line in 

the symbology window. The pop-up window is very similar to the window in Figure 14. Please choose 

School 1  for each class. And no need to worry about the color: ArcMap manages this automatically. 

 

Figure 118. Classified Symbols and Further Customization 

1 
2 

3 

4 

Symbology Customization for 
an Individual Class 
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Label 

The labels are an important feature of a map. In order for people to recognize unique attributes of a 

feature, you need to label the features. Labels help make your map more useful, informative, and 

visually appealing.  

To add labels to your map, right-click on the layer that you want to add marks on (public_school) and 

select Properties (Figure 12). Then follow the steps below: 

1. Under the Labels tab, check the box to “Label features in this layer”.  

2. Choose the attribute you want to label from the dropdown menu next to Label Field (Figure 19). 

3. Change Font (10 pt size and Bold), so that it is clearly shown on the map. 

4. You can click on the Apply button to see the effect until it is satisfactory. Then click OK to save 

your setting and exit. 

 

Figure 129. Label Setting Window 

To ensure a clear label, you can add a halo around the lettering. Click on Symbol located in the Text 

Symbol section of the window (Figure 20). Then click the Edit Symbol button, navigate to the Mask tab 

shown in Figure 18 below. Change the Style from None to Halo. 

1 

2 

3 

4 
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Figure 20. Change Mask Option for Clearer Labels 

 

 

2.2.3. Annotations 

Annotations are a method of labeling your features that offer more control over the placement of each 

label. Annotation can also be used for additional data that may not be part of your layers. For instance, 

we can add a point showing the location of the University of Waterloo, which is not part of the current 

data (Please note that annotations can only be edited under the data view): 

1. Turn on the Draw toolbar by choosing Customize -> Toolbars -> Draw (Figure 21).  

Symbology Types and Their Normal Usage: 
 Features: Mainly used when you just want to mark geographic features on a map. 
 Categories: Suit for the case when feature classification is needed. 
 Quantities: Appropriate when numbers involve, i.e., population, income, depth, etc. 
 Charts: Employed when not only quantity but also the relative importance is important as 

well. For instance, incomes from different types of consumers. 
 Multiple Attributes: Utilized when multiple criteria are involved, which main not be 

quantitative. It can be regarded as a generalized case of Charts. 

Mask Option 
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Figure 21. The Way of Turning on the Draw Toolbar 

2. Add Marker. Click on  and select Marker. Then browse and point to the location you want 

to add the marker (South Campus Hall in this case) and click. A marker will be added to the 

location. 

 

Figure 132. The Draw Toolbar 

3. A Add Text. Click   and choose New Text. Click on the map, somewhere close to the marker 

you just made and type “University of Waterloo” (result is shown in Figure 23). 
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Figure 143. Map after Adding Labels (with Mask) and Annotations 

Some Other Types of Annotations: 
 Annotate a polygon: Sometimes you may want to annotate a polygon. The easiest way to 

do so is to choose Polygon Text. Please modify the text style (color, size, etc) and the filled 
color accordingly, which locates at the right part of the Draw Toolbar (Figure 19). 

 Annotate along the road: ArcMap also allows to you to put your annotations warp along 
the road, which looks nicer. To do so, please choose Splined Text. Then make single clicks 
along the road, which defines the display route. Type in the texts and enter. The text will 
be shown along the route you made. 
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2.3. Map Components 
Switch to Layout View to start adding map components, which can be accessed from the Insert menu 

(Figure 24). The key ones are: 

 The title of the map (Purpose/Content) 

 The scale of the map (Measurement) 

 The North Arrow (Orientation) 

 The Legend (how to interpret the map) 

 (Optional) The reference (where you obtain the data) 

 

Figure 24. All Map Components Available 

Map titles are just a specific kind of text box with some pre-defined fonts. Hence, the usage of title and 

text are identical and intuitive: type in the content and customize the text properties. 

Add scale bar or scale text is also intuitive. The only thing that should be noted is the display unit, such 

as meters, degrees, miles, etc. You can change it by clicking the Properties button in the Scale Bar (or 

Text) Selector, which is the pop-up window when you choose Insert -> Scale Bar (or Scale Text).  In the 

Scale and Units tab, you can choose an appropriate unit in the Division Units dropbox (Figure 25). In 

addition, you can change the font style under the Format tab as well.  

In this example, use Scale Text with meters for the units, shown as . 

Adding a North Arrow is an easy but often overlooked task. It is similar to adding a scale bar in that you 

simply choose a pre-defined north arrow from the library shown in the left pane. If your North Arrow is 

difficult to be distinguished from the background, you can add some background color, which has a 

similar effect as “mask” for labels. This option is normally located in the Frame tab (Figure 26). Legend, 

scales, and texts all have similar options. 

1 cm = 75 meters
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Figure 155. The  Scale Bar (or Text) Property Window 

 

Figure 166. Change Background Color in Frame Tab 

Adding a Legend is somewhat complex and deserves some explanation. When Insert -> Legend is 

selected, ArcMap will use a wizard guiding you through various options of making a legend.  

At the first step, you will be asked about which layers you’d like to include in the legend and the order of 

those layers (Figure 27). The left pane Map Layers displays all layers (geospatial data) available for the 

map. The right pane Legend Items shows the layers that will be added to the legend and their order.  

 Add/Remove Layers: You add layers to the legend by clicking  and remove them by clicking 

. Note: Although you can add the basemap to your legend, it will not have any symbol next 

to it because it is a tiled map service; however, the basemap information is automatically 

included at the bottom of the map when in Layout View. Similarly, if you add a raster to your 

legend, it will only show the RGB or other relevant values. 

Division Unit Dropbox 

Background Color Change 

Frame Tab 
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 Change the Display Orders: The legend items will be added strictly in the order shown in the 

Legend Items pane. You can change the order by clicking a layer first (displayed in the blue bar) 

and move it up  or move it down . 

 

Figure 177. The First Step of Adding Legend 

In the following three steps (four steps in total), ArcMap will ask you about some options to display the 

legend. None of them is critical or requires customization (especially for normal users). You can just 

accept all the defaults and click Next until you get to the end. Your legend should look something like 

Figure 28 below. 

  

Figure 188. An Example of Generated Legend 

It is easy to find that the name displayed in the legend is either difficult to understand or looks strange 

because of how the file was named. For instance, users can understand what “waterloo_city” means, 

but it doesn’t look good in all lowercase letters and with the underscore. In this case, you can modify the 

name in the table of contents pane (Figure 4). To do so, you can right-click on the “waterloo_city” layer 

and select Properties. Under the General tab, you can type the more meaningful name in the Layer 

Name: Waterloo City Limits (Figure 29). Use the same method to change any other obscure names. 

 

Obscure Name 
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Figure 199. The General Tab to Change Layer Name 

Lastly, we’re going to add a citation to the map.  Click on Insert -> Text under the layout view and type 

in your citation.   

 

Figure 30. Property Window of Text in Layout View 

Customize Layer Name 

Type in/Modify Text Here 
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Some Components that are also frequently added: 
 Author of the Map: Users may want to know who creates the map; 
 Date Saved (Created/Modified): The more frequent a region changes, the more important 

it is for users to know when the map is created; 
 Coordinate System: The globe is not flat, but a map is. Any kind of projection used to make 

the map distorts the reality in some way. Hence, it is critical for users to know how 
reliable their measurements on the map are, especially for pilots and navigators. 
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2.4. Export Maps 
When you are satisfied with everything in the map and are ready to deliver, you can export your map by 

the menu of File -> Export Map, which will pop-up a dialog (Figure 31).  

 

Figure 31. Export Map Dialog 

You can specify the directory and file name of the map in this dialog. But, most importantly, you need to 

choose an appropriate file format by click on the Save as type dropbox. The most frequent-used formats 

are JPEG and PDF. JPEG is a popular graphic file format, which is easy to be inserted into word as a 

graph, while PDF is best used for sharing. The printed copy of PDF will be identical regardless of your 

computer (and printer) environment.  

Please note that if the purpose of your map is to be shown on screen, 96 dpi resolution is good enough. 

It is especially true when you want to publish your map online, given that lower resolution maps are 

much smaller, and therefore, easier to transfer via Internet. If you need hard copies of your map, please 

make sure that the resolution is set to 300 dpi or 600 dpi. Otherwise the output map might be obscure. 

Other than export map to other file formats, you can directly print out hardcopies of your map by File -> 

Print. You can preview the result via File -> Print Preview to ensure satisfactory result. And, of course, 

you can customize page and printer setup via File -> Page and Print Setup, such as page orientation 

(portrait and landscape), page size, printer configuration (color or grey), and so on. All these operations 

are intuitive and very similar to other applications, such as Microsoft Word.  

 

Choose File Format Here 
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The final map will look similar to the one below. 
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Tutorial Created by Qian Wang in 2011 

Updated by Steve Xu in 2012 and Talsan Schulzke in 2014 

 

Brief Explanation of Graphic File Formats: 
 

 EMF file:  Enhanced Metafile, specified for Windows, which can be regarded as an 
alternative of TIFF file. EMF is an not recommended option; 

 EPS file: Enhanced PostScript file, specified by Adobe for printer drivers. It is popular in 
open-source editors, for instance, LaTeX and TeX. But it seems to be a buggy option. Try to 
avoid it; 

 AI file: Adobe Illustrator file. A major vector graphic file format. A good choice if you work 
with Adobe products, such as Illustrator, Flash, and MacroMedia ones; 

 SVG file: Scalable Vector Graphics, an open-source vector graphic standard. It is becoming 
more and more popular and can be accepted by many vendors; 

 BMP file: BitMap file, which is a mature loss-less uncompressed raster format. The quality 
is great. But its file size tends to be huge. It can be used if you need both high-quality 
output and compatibility ; 

 PNG file: Portable Network Graphics, which is an open-source standard designed to 
replace BMP and GIF. It is a true-color loss-less raster file format. PNG file is slightly 
larger than JPEG (compressed with quality loss). And some old browsers and operating 
systems do not support PNG files; 

 TIFF file: Tagged Image File Format. A major raster graphic file format provided by 
Adobe (AI for vector). Best to be used for raster file editing on Adobe Products, such as 
Photoshop; 

 GIF file: Graphics Interchange Format. An uncompressed raster file format with 256-color 
limitation. Hence, if your map contains only a few colors (vector-based data), GIF is a 
good candidate.  


