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Creating Maps in QGIS: A Quick Guide 

Overview 
Quantum GIS, which is often called QGIS, is an open source GIS desktop application. Comparing to 

ArcGIS, QGIS can be installed on various operating systems, such as Windows, Mac OS X, Linux (Ubuntu), 

and Unix, while ArcGIS only has Windows version. More importantly, QGIS is FREE and has many plugins, 

adding different functions. However, since QGIS mainly relies on community support and voluntary 

developers, it does not have abundant documents and sometimes is not intuitive to use. Hence, making 

maps in QGIS needs some explanation. The two major steps, browsing data and making maps, are 

divided into five parts shown in the following table: 

 

No. Steps 
Sections 
to check 

Difficulties 

1 Load Geospatial Data into QGIS 1.1 Data formats 

2 
Identify the features and attributes to 
present 

1.2  
Layer order, feature selection, and 
(briefly) frequent-used projections 

3 Define how to show the data 2.1 
Transparency (raster and vector), data 
classification, and layer file 

4 Add maps components 2.2 Geospatial data references 

5 Export maps 2.3 File formats 

 

Table of Contents 
1. Browse Geospatial Data .......................................................................................................................2 

1.1. Load Data ......................................................................................................................................2 

1.2. Browse the Data ...........................................................................................................................6 

2. Mapping................................................................................................................................................9 

2.1. Key Options of Geospatial Data Representations ........................................................................9 

2.2. Map Components ...................................................................................................................... 15 

2.3. Map Printing (Exporting) Options .............................................................................................. 18 

Note: This document can be read in a “non-linear” manner: 

 Possible problems are covered in coloured regions: Knowing how to address these problems are not 

quite relevant to the main process, but might be useful in practise. Hence, they are covered in 

coloured regions, which you can skip when you want to go through the process and no error pops 

up. You can come back whenever you meet problems; 

 Section number and title is shown at the top of every page: If you have known what kind of problem 

you have, you can “jump” to the section where discusses it. 
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1. Browse Geospatial Data 

1.1. Load data 

To launch QGIS, click: Start -> All Programs -> QGIS -> QGIS. QGIS normally adds the version number 

after “QGIS”, which is currently 1.5.0 (code name Tethys).  The main windows of QGIS can be divided 

into three regions shown in Figure 1. 

 
Figure 1. The Main Window of QGIS showing Regions 
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Click the Add Vector Layer  button to add geospatial data (Figure 2), which opens a window (Figure 

3). 

 
Figure 2. The Main Window : Add Vector Layer button 

 
Figure 3. The Pop-up Window to "Add Vector Layer" 

Then you can browse to the file you want to work with by clicking the Browse button just like any other 

file explorer dialogs in Windows. You can open multiple files at one time by holding the Ctrl or Shift 

button when you are clicking the mouse button to make selections. The by-default file filter is *.shp file 

(Figure 4). But there are many other choices, such as *.kml (Google Earth) and *.tab (MapInfo), much 

broader than ArcGIS.  

 

Figure 4. The File Open Dialog with File Filters 

Load all data listed in Figure 4 into QGIS. 

Add Data 

Add Data 
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Load Google Maps. 
QGIS provides the flexibility of using Google (or Yahoo) Satellite images as a background layer in 
your map. To do so, follow the steps below: 

0. Install the OpenLayers plugin into QGIS:  
a. Go to Plugins -> Fetch Python Plugins, which leads to a dialog. 
b. Switch to the Repositories tab and click the Add 3rd party repositories button. 

 
c. Switch back to the Plugins tab and search for Openlayers (you can type in 

“openlayers” in the filter), then select the “Openlayers plugin” and click the Install 
plugin button. 

 
1. Add Google Maps as the background layer: Go to the menu Plugins -> Openlayers plugin 

->Add Google Hybrid Layer. 
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Frequently-used File Formats in QGIS: 
 Feature Data: Feature data are usually organized as points, lines, and polygons in vector 

format. 
o Shapefile: The most commonly used geospatial data format. Although it appears to 

be one file in ArcMap, shapefile includes multiple files with the same file name, but 
different extensions. *.shp, *,dbf, and *.shx are must-have.  

o Personal Geodatabase: These files are based on Microsoft Access (*.mdb). From user 
perspective, all kinds of geodatabase are the same, which include multiple layers 
(different geospatial data) in one geodatabase. 

o MapInfo files: The following three are legendary geospatial file formats. MapInfo is 
the first desktop GIS software for Windows. Its files (*.tab) are widely used.   

o MicroStation files: MicroStation files have the extension of *.dgn, whose vendor is GE. 
Electricity plants often use it.  

o ArcInfo: ArcInfo is the previous generation of ArcGIS. Its file (*.e00) are supported in 
QGIS as well. 

o Google Earth: *.kml and *.kmz (zipped KML) are Google Earth file formats, which are 
popular in Location-Based Service now. Many websites support kml and kmz files. 

o GML and GeoJSON: Open source geospatial data standard, which is also popular in 
online applications. 

o GPS: The track of GPS records can be imported into QGIS as *.gpx files. This function is 
very useful in surveying. 

o CSV: *.csv files stands for comma separated value, which can be regarded as a 
legendary spreadsheet file format.  

o US Census TIGER: US census publishes its data in tiger format, which belongs to 
“directory” source type rather than “file”. 

 Raster Data: Raster data uses grid to represent a region with values as a “field”. Images 
explicitly have the parameter of resolution. Typical raster data is: 

o GeoTIFF: They have the file extension of *.tif. The key difference between normal TIFF 
file and GeoTIFF is that GeoTIFF has projection information. Hence, normal TIFF files 
cannot be correctly added to the desired location. 

o GeoJPEG: Similar to GeoTIFF, but they have *.jpg extension. 
o Usage: Raster data can be air photos, satellite images, elevation data (DEM). But 

raster data tends to be huge and slow to load. 
 Stronger Database Support: 

One major advantage of QGIS over ArcGIS lies in its superior support of different database 
vendors. Almost all types of relational database management system (RDBMS) are 
supported. 
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1.2. Browse Geographic Features 
Most controls to browse data are located in two tool bars (Figure 5), which are also available under the 

View menu. If you cannot find this toolbar, go to View -> Toolbars and check the Map Navigation on.   

 

Figure 5. The Toolbar with Data Browsing Controls 

Most icons are intuitive and self-explained. If you are not sure what function it has, hover your mouse 

over that icon. A pop-up text will show with further explanations.  

One difference between QGIS and ArcGIS is the layer related operations. In QGIS, all layer related 

operations must be conducted after the target layer has been selected, such as feature identification, 

feature selection, and attribute table operations. 

To open the attribute table, you can either right-click at the layer and select “Open attribute table”, or 

click the open attribute table button in the toolbar (Figure 6). 

 

Figure 6. The Pop-up Window with Options on a Layer 

The feature selection function in QGIS is not as powerful as ArcGIS. There are two ways to choose a 

subset of features. One is “select by dragging a rectangle” by clicking . The other is by right-clicking 

the layer, then selecting “Query” (Figure 7). You can form SQL statements to select features based on 

attributes. 

Open Attribute 
Table 
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Figure 7. The Query Builder Window 

Another interesting feature is “Zoom to layer extent” shown in Figure 6. Sometimes you may lose sight 

of your map display. If so, you can zoom back to the desired region by clicking Zoom to layer extent. 

 

 

Brief introduction to geographic information: 
 Vector Data: Vector data contains two parts: a geographic feature on the map (i.e. bus stops) 

and an associated record in the table with all its attributes (i.e. routes, arriving times, etc). 
The separation of attribute table and geographic feature is critical, because most operations 
in ArcGIS are organized based on this classification. 

 Raster Data: Raster data is a set of cells with values, which is normally added as reference 
background in mapping or included for further analysis. Normally, users will not identify or 
modify raster data for mapping purpose. 

 Networks: A kind of typical networks is roads. Finding the nearest way to a destination via 
roads is a frequently used operation. Please find more in the further reading if interested. 

 Further Reading: Michael Zeiler, Modeling Our World, ESRI Press, 2nd Edition, 2010. 

Add Raster Data: QGIS explicitly differentiates vector and raster data format. To add raster 

data, the Add Raster Layer button  should be clicked. The main reason is that raster data is 
supported via another open source module called GDAL, which adds powerful operations or 
raster data processing.  
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Geospatial Data Projections: 
 The globe is not flat, but a map is. Any kind of projection used to make the map distorts the 

reality in some way. Hence, when Google maps or any other third party layer is included, 
different projections are likely to be used, leading to a problem of mismatch.  

 To obtain the projection information of a layer (and the map) right-click on the layer, then 
select Properties (Figure 8). Projection information is located under the General tab. 

 
 You can specify (check the projection code) by clicking the Specify CRS button. Frequently 

used projections are: 
o WGS 84: Used in GPS systems with longitude/latitude measurement. You can find it 

using either ESPG code 4326 or CRS ID 3452; 
o Google Mercator: Used by major online mapping services, including Google, Microsoft, 

and OpenStreetMap. Its ESPG code is 900913, while CRS ID 3644; 
o UTM zone system: UTM system is often employed in northern country mapping. 

Waterloo, Ontario, Canada belongs to UTM zone 17N, which can be found wit ESPG: 
26917 and CRS ID 2294. 

 If different layers cannot combine, go to the menu Settings -> Project Properties, and 
specify a project in the Coordinate Reference System (CRS) tab of the pop-up window. 
Check all layers’ projections if there are still problems. Mismatch is usually caused by 
incorrect use of projections. 



2.1 Key Options of Geospatial Data Representations 

Page 9 of 18 

2. Mapping 

2.1. Key Options of Geospatial Data Representations 
Main options of changing geospatial data representations include layer order, layer transparency, 

symbology, label, and annotation. Apart from the first one (layer order) and last one (annotations), all 

the rest are located in the pop-up window (Figure 8) when you right-click the layer you want to modify 

and select property (Figure 9). They are under either the symbology or labels tab.  

 

Figure 8. The Pop-up Window of a Layer's Property 

 

Figure 9. The Property Window 

All options will be introduced as subsections in the following. 

2.1.1. Layer Order and Transparency 

QGIS displays geospatial data according to the order in the table of contents: the bottom layer will be 

drawn on the screen first and covered by upper layer. Hence, the layer on the top in the table of 

Properties 

Symbology 

Labels 
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contents will be displayed as the top layer in the map. Unlike ArcMap, QGIS will not order layers 

automatically.  

When a point-feature layer is put under a polygon-feature layer, the point-feature one is covered and 

invisible. You can change layer visibility by switching the checkboxes left to the layer name in table of 

contents (Figure 10). And the display order can be changed by simply dragging the layer toward or away 

from the top.   

 

Figure 10. Layer Visibility and Order Control 

When a polygon layer, such as buildings or parcels, is added over an image, the content on image under 

the building is often invisible. But sometimes users like to only show the parcel’s boundary and keep the 

image displayed. In this case, layer transparency and hollow symbology can help.  

To do so, right-click on the polygon layer and select Properties first (Figure 8). Then switch to the tab 

Symbology and click on the symbol itself (Figure 11). You can make polygons hollow by changing Fill 

options from solid to none. Alternatively, you can change the Transparency ratio as well. 

Visibility 
Checkbox 

Drag to change order 
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Figure 11. Properties of Symbology 

 

2.1.2. Symbology and Label 

Symbology is critical in making maps, which are classified into four Legend type in QGIS (on the top of 

Figure 11). Due to its complexity, these four categories and their normal usages will be briefly 

introduced in the note region with further reading. We will only focus on symbol customization and 

classification symbols, which are mostly used. 

Unlike ArcMap, QGIS does not hold a large library of professional symbols. In fact, only point-feature 

layers can have different symbols (Figure 12), while line and polygon layers can only change line and fill 

options.   

 

Figure 12. The Symbology Customization Window 

Symbology Tab 

Click on the Symbol to 
Customize 

Change the 
Transparency Bar 
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Depending on the type of the feature (point, line, or polygon), the options in Figure 12 changes 

accordingly. For polygons, it has the most options: fill color, boundary width, and boundary color. For 

lines, only color and width show up. Points also have two options (color and size). 

There are cases when you want to differentiate features in a layer based on some attribute. For 

instance, I want to know which schools are public, separate, or for higher education in the schools layer, 

which is the top layer in Figure 10. Different types will be marked in colors. To do so, we should right-

click on the school layer, select properties, and go to the symbology tab, which is the same as shown in 

Figure 11. But, instead of by-default Features option, we should click and select the categories option 

(Figure 15). The steps to follow are also shown in Figure 15:  

1. Click on the Legend type first and make sure the “Unique Value” is chosen; 

2. Pull down the dropbox of the Classification field, and select TYPE as the classification attribute; 

3. Click on the Classify button to add all distinct values under the TYPE attribute into consideration; 

4.  (Optional) Click on the Randomize dropbox and change colors. 

 

Figure 13. Classifying Features using Colors 

Note that you can still customize individual symbols for each category (size, shape, etc) by double 

clicking the corresponding class on either the left pane or the line in symbology window (Figure 13).  

The labels are an important feature of a map. By marking some property up on the map, for instance the 

name of the marked location, labels can make your map more useful, informative, and visually 

appealing.  

To add labels to your map, right-click on the layer that you want to add marks on and select Properties 

(Figure 8). Then follow the steps below: 

1. Select the Labels tab and check on (off by default) “Display labels”.  

1 
2 

3 

4 
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2. Choose the attribute you want to display on the map in the dropbox of Field Containing label 

(Figure 14). 

3. Change Font, so that it is clearly shown on the map. 

4. You can click on the Apply button to see the effect until it is satisfactory. Then click OK to save 

your setting and exit. 

5. (Optional) If you think the added labels are not distinct on the map background, you can make a 

buffer background around the texts. Please scroll down and check Buffer labels, which has the 

same effect of “mask” in ArcMap. 

 

Figure 14. Label Setting Window 

Note: Alternatively, you can accomplish most jobs by clicking  shown in Figure 5. Only the “buffer” 

function is missing. 

 

Symbology Types and Their Normal Usage: 
 Single Symbol: Mainly used when you just want to mark geographic features on a map. 
 Graduated Symbol: Graduated symbol marked attributes with decretive numbers in a 

statistical way, which can only applied to attributes with numbers. 
 Continuous Color: Continuous color can represent continuous values, such as population 

density, elevation, and so on. 
 Unique Value: Unique value gives every possible value of an attribute a distinct symbol 

(mainly based on colors). Unique value can be applied to all kinds of attributes.  
 Diagram Overlay: Unlike ArcMap, QGIS places multiple attribute mapping into an 

independent tab called diagram overlay. Information like the percentage of populations 
in different age intervals at different locations can be easily shown in this way. 

1 

2 

3 

4 

4 



2.1 Key Options of Geospatial Data Representations 

Page 14 of 18 

2.1.3. Annotations 

Annotations look like labels. The key difference is that annotation can be any text you want to add on 

the map, regardless to whether the information has been included in the geospatial data. 

For instance, if you want to add a point at the entrance of uWaterloo, which is not in the geospatial 

data, Simply click  on the toolbar shown in Figure 5. 
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2.2. Map Components 
When the geospatial data and its representations are satisfactory, you can add other map components 

in another window via File -> Print Composer (Figure 15). You can manage multiple composers via File -

> Composer Manager. Key components include: 

 The title of the map; 

 The scale of the map; 

 The North Arrow (Orientation); 

 The Legend (how to interpret the map); 

 (Optional) The reference (where you obtain the data). 

 

Figure 15. The Map Composer Window 

Firstly, please note that, unlike ArcMap, the by-default page size is A4 (not letter size). Since letter size is 

more popular in North America, you might want to change to letter size, which is called “ANSI A” in 

QGIS. 

Change Paper Size 

Customize Component 
Properties 
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The main part, map, can be added by clicking  in Figure 15, and then drag a rectangle on the paper 

to define display area and extent. 

Map titles can be added as a text box by clicking  and then click on the spot where you want to place 

the title at. Please note that, in print composer, you can customize the properties of all components by 

switching to the ITEM tab. So, for instance, if you want to change the font of the title, click the title first 

(so that it is selected) and change to the ITEM tab. There is a button called Font where you can find all 

properties there. 

Add scale bar is also intuitive: click on  and then click where you want to add it. You can change Unit 

label and Style. The scale bar style can be numeric, i.e. 1:5,000,000, or different bar/line forms. All 

options are intuitive and can be tested by changing it back and forth. 

North Arrow can be added as an arrow. The options of a north arrow in QGIS are very limited.  

Legend can be added in the same way as others (click on ).  QGIS has better organization of legend 

properties than ArcMap (Figure 16). The major options are located under Legend items. You can fine 

tune in Item Options. 

 

Figure 16. The Legend Property Window 

Change Item Options 

Major Options 
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The initial generated legend looks like Figure 17. We can find that there are several obscure layer 

names. For instance, ordinary users will not know the meaning of “SLSN_google”. To change the name, 

you can select the layer “SLSN_google” first; then click the Edit button and change its name to “Roads” 

in the pop-up window. Other options are intuitive, enabling you to change the order, remove unwanted 

layer in legend, and group layers in a more meaningful way, and so on. 

 

Figure 17. An Example of Generated Legend 

Some Components that are also frequently added: 
 Author of the Map: Users may want to know who creates the map; 
 Date Saved (Created/Modified): The more frequent a region changes, the more important 

it is for users to know when the map is created; 
 Coordinate System: The globe is not flat, but a map is. Any kind of projection used to make 

the map distorts the reality in some way. Hence, it is critical for users to know how 
reliable their measurements on the map are, especially for pilots and navigators. 

Obscure Name 
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2.3. Export Maps 
When you are satisfied with everything on the map and are ready to deliver, you can export your map as 

images, PDF, SVG, or print a hard copy. All options are under the File menu. 

You can specify the directory and file name of the map in this dialog. But, most importantly, you need to 

choose an appropriate file format by clicking on the Save as type dropbox. The most frequent-used 

formats are JPEG and PDF. JPEG is a popular graphic file format, which is easy to be inserted into word 

as a graph, while PDF is best used for sharing. The printed copy of PDF will be identical regardless of 

your computer (and printer) environment.  

 

Brief Explanation of Graphic File Formats: 
 SVG file: Scalable Vector Graphics, an open-source vector graphic standard. It is becoming 

more and more popular and can be accepted by many vendors; 
 BMP file: BitMap file, which is a mature loss-less uncompressed raster format. The quality 

is great. But its file size tends to be huge. It can be used if you need both high-quality 
output and compatibility ; 

 PNG file: Portable Network Graphics, which is an open-source standard designed to 
replace BMP and GIF. It is a true-color loss-less raster file format. PNG file is slightly 
larger than JPEG (compressed with quality loss). And some old browsers and operating 
systems do not support PNG files; 

 TIFF file: Tagged Image File Format. A major raster graphic file format provided by 
Adobe (AI for vector). Best to be used for raster file editing on Adobe Products, such as 
Photoshop; 

 GIF file: Graphics Interchange Format. An uncompressed raster file format with 256-color 
limitation. Hence, if your map contains only a few colors (vector-based data), GIF is a 
good candidate.  


